原来挺复杂的因为要去对应PHP版本,不说下错版本安装不上,下对了也不一定,后来有高人集成到了git上,又让我丧失了一项技能,只能跟着走


步骤1
git clone https://github.com/laruence/yaconf.git
步骤2
cd yaconf/
phpize
./configure --with-php-config=/www/server/php/72/bin/php-config
make
make install
步骤3
vi /www/server/php/72/etc/php.ini
在最底部增加
extension=yaconf.so
/etc/init.d/php-fpm-72 restart

然后用phpinfo测试是否正常